I just started a new Rails 3.1 project, and got the following error:

/gems/execjs-1.2.4/lib/execjs/runtimes.rb:45:in `autodetect': Could not find a JavaScript runtime. See
https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)

The fix:

sudo apt-get install nodejs

I bet this has something to do with coffeescript, but I haven’t started with it yet, so I can’t say for sure.

¥