I have an old copy of Windows 2000 installed in a QEMU image which I’m still planning to use. Now that I’ve finally gotten my hands on a cheap laptop that supports KVM extensions, (KVM is an advanced version of QEMU with integrated CPU-capabilities, like AMD-V and Intel VT, support) I’m running Windows updates and its cool to learn that Microsoft still has the updates online.

I’m now wondering if Internet Explorer 6.0 is the most recent version that can run on W2K. I can install Firefox, but apparently Google’s Chrome requires at least Windows XP.