Docunext


PHP LDAP Admin Errors

April 6th, 2010

I'm trying to login to my phpldapadmin installation but I'm getting these errors:

E_STRICT: Declaration of AJAXTree::draw_dn() should be compatible with that of PLMTree::draw_dn()

and

error (a:5:{i:0;s:97:"E_STRICT: Declaration of AJAXTree::...<TRUNCATED>)

I'm uninstalling it and reinstalling it... that of course didn't help. This did:

which points to this diff for /usr/share/phpldapadmin/lib/AJAXTree.php:

16c16
<       protected function draw_dn($dn,$level=0,$first_child=true,$last_child=true) {
---
>       protected function draw_dn($dn,$level,$first_child=true,$last_child=true) {

¥

Yearly Indexes: 2003 2004 2006 2007 2008 2009 2010 2011 2012 2013 2015 2019 2020