Looks like the new version of sitecopy in Squeeze is having problems. I get this error:

sitecopy: Error: Could not connect to server...

I did a quick search and someone else is having the same problem. Doh!

I downgraded to the one from Etch, which requires libneon26, and that works.

Hmmm, I think whatever is wrong here might be due to libneon27, as I’m not able to use svn either!

This might be the problem: Debian Bug report logs - #531338 :: svn: OPTIONS of ‘http://…’: could not connect to server (http://…)

Yup, needed to update libneon27 and libneon27-gnutls from sid.