I am still having a bit of trouble figuring out the right limits for virtual environments in OpenVZ. I just ran into some limits, but I’m not sure what they represent:

      101:  kmemsize        4798090    5456277   12752512   15936012          0            lockedpages           0          0         64         64          0            privvmpages      246621     248731     250000     350000          0            shmpages          34381      83227     181920     181920          0            dummy                 0          0          0          0          0            numproc             119        128        165        265          0            physpages         34308      35376          0 2147483647          0            vmguarpages           0          0       6144 2147483647          0            oomguarpages      34308      35376       6144 2147483647          0            numtcpsock            8         48         80         80          0            numflock              6         12        100        110          0            numpty                1          2         16         16          0            numsiginfo            0          6        256        256          0            tcpsndbuf         84360     368520    1319488    1524288          0            tcprcvbuf        131072     852572    1319488    1524288          0            othersockbuf     157876     232720     232096     436896       3475            dgramrcvbuf           0      16728     132096     132096          0            numothersock        112        131        180        180          0            dcachesize            0          0    1048576    1097728          0            numfile            2011       2048       2048       2048       1290            dummy                 0          0          0          0          0            dummy                 0          0          0          0          0            dummy                 0          0          0          0          0

othersockbuf and numfile

One problem I have yet to figure out is that when I restart a virtual environment that has a mysql clone running on it, it won’t start the clone automatically. I have to login to mysql and start it. I seem to think that regular machines will start automatically, right?

UPDATE - I just figured out what the problem was with mysql replication auto-start on openvz.