Just updated courier-imapd-ssl on debian and got this error in the logs and was unable to connect:

connect: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

For some reason, my existing /etc/courier/imap-ssl file had:

TLS_PROTOCOL=SSL3

I changed it to:

TLS_PROTOCOL=SSL23

And everything worked fine again. Hope that helps!

Courier page in the Docuwiki

UPDATE: Hit another snag on another update:

Lenny Courier Woes

¥