Just a quick note, I’ve been running FreeBSD 6.2-RELEASE FreeBSD 6.2-RELEASE #0 on the intel little valley for several months and it works great. I’m not running X, so I don’t know how the video driver works, but for me the network, IDE, and all the basics work. I haven’t experienced any problems so far.

Here’s a dmesg:

Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.2-RELEASE #0: Sat Jul 21 04:46:25 UTC 2007:/usr/obj/usr/src/sys/GENERIC
ACPI APIC Table:
<INTEL  DG965CO >
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Celeron(R) CPU          215  @ 1.33GHz (1333.39-MHz 686-class CPU)  Origin = "GenuineIntel"  Id = 0x6e8  Stepping = 8  Features=0xafe9fbff
<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,TM,PBE>  Features2=0xc109
<SSE3,MON,TM2,
<b14>,
<b15>>  AMD Features=0x100000
<NX>
real memory  = 1038565376 (990 MB)
avail memory = 1006194688 (959 MB)
ioapic0: Changing APIC ID to 4
ioapic0
<Version 1.4> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0:
<INTEL DG965CO> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0:
<24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0:
<ACPI CPU> on acpi0
acpi_throttle0:
<ACPI CPU Throttling> on cpu0
pcib0:
<ACPI Host-PCI bridge> port 0xcf8-0xcff iomem 0xfff00000-0xffffffff on acpi0
pci0:
<ACPI PCI bus> on pcib0
pcib1:
<ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1:
<ACPI PCI bus> on pcib1
pci1:
<display, VGA> at device 0.0 (no driver attached)
isab0:
<PCI-ISA bridge> at device 2.0 on pci0
isa0:
<ISA bus> on isab0
atapci0:
<SiS 964 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x2280-0x228f at device 2.5 on pci0
ata0:
<ATA channel 0> on atapci0
ata1:
<ATA channel 1> on atapci0
pci0:
<multimedia, audio> at device 2.7 (no driver attached)
ohci0:
<SiS 5571 USB controller> mem 0x4a104000-0x4a104fff irq 20 at device 3.0 on pci0
ohci0: [GIANT-LOCKED]
usb0: OHCI version 1.0, legacy support
usb0:
<SiS 5571 USB controller> on ohci0
usb0: USB revision 1.0
uhub0: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1:
<SiS 5571 USB controller> mem 0x4a103000-0x4a103fff irq 21 at device 3.1 on pci0
ohci1: [GIANT-LOCKED]
usb1: OHCI version 1.0, legacy support
usb1:
<SiS 5571 USB controller> on ohci1
usb1: USB revision 1.0
uhub1: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
ohci2:
<SiS 5571 USB controller> mem 0x4a102000-0x4a102fff irq 22 at device 3.2 on pci0
ohci2: [GIANT-LOCKED]
usb2: OHCI version 1.0, legacy support
usb2:
<SiS 5571 USB controller> on ohci2
usb2: USB revision 1.0
uhub2: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ehci0:
<EHCI (generic) USB 2.0 controller> mem 0x4a101000-0x4a101fff irq 23 at device 3.3 on pci0
ehci0: [GIANT-LOCKED]
usb3: waiting for BIOS to give up control
usb3: timed out waiting for BIOS
usb3: EHCI version 1.0
usb3: companion controllers, 3 ports each: usb0 usb1 usb2
usb3:
<EHCI (generic) USB 2.0 controller> on ehci0
usb3: USB revision 2.0
uhub3: SiS EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub3: 8 ports with 8 removable, self powered
sis0:
<SiS 900 10/100BaseTX> port 0x2000-0x20ff mem 0x4a100000-0x4a100fff irq 19 at device 4.0 on pci0
miibus0:
<MII bus> on sis0
ukphy0:
<Generic IEEE 802.3u media interface> on miibus0
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
sis0: Ethernet address:
pcib2:
<PCI-PCI bridge> at device 31.0 on pci0
pci2:
<PCI bus> on pcib2
acpi_button0:
<Power Button> on acpi0
atkbdc0:
<Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0:
<AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
ppc0:
<ECP parallel printer port> port 0x378-0x37f,0x778-0x77b irq 7 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
ppbus0:
<Parallel port bus> on ppc0
plip0:
<PLIP network interface> on ppbus0
lpt0:
<Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0:
<Parallel I/O> on ppbus0
sio0:
<16550A-compatible COM port> port 0x2f8-0x2ff irq 3 flags 0x10 on acpi0
sio0: type 16550A
pmtimer0 on isa0
orm0:
<ISA Option ROMs> at iomem 0xc0000-0xcffff,0xd0000-0xd9fff on isa0
sc0:
<System console> at flags 0x100 on isa0
sc0: VGA
<16 virtual consoles, flags=0x300>
vga0:
<Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1333387980 Hz quality 800
Timecounters tick every 1.000 msec
ad0: 76318MB
<WDC WD800JB-00JJC0 05.01C05> at ata0-master UDMA100
Trying to mount root from ufs:/dev/ad0s1a

¥