Just added my experience to bug #58232 at Ubuntu’s launchpad.net:

I'm running 2.6.20 32-bit on AMD64 with xinerama and NVidia card - no terminal action here.
Section "Device"
    Identifier "0 Generic Video Card"
    Driver "nvidia"
    BusID "PCI:5:0:0"
    Screen 0
    Option "AddARGBGLXVisuals" "True"
    Option "DisableGLXRootClipping" "True"
    Option "XAANoOffscreenPixmaps" "true"
EndSection
Section "Device"
    Identifier "1 Generic Video Card"
    Driver "nvidia"
    BusID "PCI:5:0:0"
    Screen 1
    Option "AddARGBGLXVisuals" "True"
    Option "DisableGLXRootClipping" "True"
    Option "XAANoOffscreenPixmaps" "true"
EndSection
Section "Screen"
    Identifier "Main Screen"
    Device "0 Generic Video Card"
    Monitor "Main Monitor"
    DefaultDepth 16
    Option "UseFBDev" "true"
    SubSection "Display"
        Depth 16
        Modes "1680x1050"
    EndSubSection
    SubSection "Display"
        Depth 24
        Modes "1680x1050"
    EndSubSection
    Option "AddARGBGLXVisuals" "True"
    Option "DisableGLXRootClipping" "True"
EndSection
Section "Screen"
    Identifier "Second Screen"
    Device "1 Generic Video Card"
    Monitor "Second Monitor"
    DefaultDepth 16
    Option "UseFBDev" "true"
    SubSection "Display"
        Depth 16
        Modes "1680x1050"
    EndSubSection
    SubSection "Display"
        Depth 24
        Modes "1680x1050"
    EndSubSection
    Option "AddARGBGLXVisuals" "True"
    Option "DisableGLXRootClipping" "True"
EndSection
Other than that, both monitors look great, and every other application I've tried works fine.

¥